[f] AMB on Facebook

Volu-Master & gamma3 v1.03 firmware released

The face and heart of the system.

Moderator: linux-works

Volu-Master & gamma3 v1.03 firmware released

Postby amb » December 17th, 2019, 12:13 pm

Admin note: The thread title has changed from "Arduino 1.8.x issues with LCDuino-1 firmware" to "Volu-Master & gamma3 v1.03 firmware released"

For both Volu-Master and gamma3 firmware prior to v1.03, if you are compiling and flashing firmware yourself, you will experience an error when using the current Arduino IDE 1.8.10. This is because the g++ compiler that comes with Arduino now has stricter data type checking. I have made the needed fixes to both firmware code to make them compile successfully with the new Arduino IDE, and will release them as v1.03 soon, after some testing to make sure there are no regressions.

Meanwhile, if you're trying to compile v1.02 of Volu-Master or gamma3, use Arduino 1.8.2 IDE or earlier which are known to work. If you're using the Makefile method to compile, then you need to use Arduino 1.6.x or earlier. The upcoming v1.03 firmware release will compile and work on Arduino 1.8.10 (and hopefully all future 1.8.x) with both the IDE or Makefile compilation methods.

This is FYI only, and does not affect anyone who is running LCDuino-1 with pre-flashed ATmega328p MCU chips from AMB audio shop.
User avatar
amb
Site Admin
 
Posts: 10555
Likes: 191 posts
Liked in: 505 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)

Volu-Master & gamma3 v1.03 firmware released

Postby amb » December 22nd, 2019, 5:52 pm

The Volu-Master v1.03 and gamma3 v1.03 firmware are both released and available for download on the LCDuino-1 website firmware page. All new pre-flashed ATmega328p MCUs from AMB audio shop will now ship with the new firmware.

If you're running firmware v1.02, there is no need to update to v1.03, because there is no functional change. The only changes are for compatibility with Arduino 1.8.x, which is relevant if you need to compile the firmware from source yourself. However, if you are running firmware v1.01 or earlier, an update to v1.03 is recommended.

NOTICE: If you have one of the first batch of prototype γ3s (With v1.0 backplane and γ24 DAC core boards), you need to edit the config.h file and uncomment the #define GAMMA3_PROTOTYPE line before compiling and flashing the firmware. The production v1.01 γ3 and γ24 boards should have this line commented out as it comes.
User avatar
amb
Site Admin
 
Posts: 10555
Likes: 191 posts
Liked in: 505 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)


Return to LCDuino-1 display I/O processor

Who is online

Users browsing this forum: No registered users and 0 guests

Quick Links

AMB audio DIY resources
AMB audio shop