[f] AMB on Facebook

Mini³ stopped working

Mini-cubed

Mini³ stopped working

Postby tube_dude » January 10th, 2019, 9:35 pm

I have a Mini3 that I put together 6-7 years ago, which I used daily. The other day it started having heavily distorted low-volume output out of the blue.
I opened it up and went through the initial check-list once again.
-- sanity check - pass
-- quiescent current check - pass (25mA)
-- rail-splitter check - pass (within <0.2V)
-- output DC offset check - FAIL: I read -2.6V on OG
I traced the DC offset on OG back to pin 3 of U4 where I have -1.3V
I checked solder joints, re-flown the solder on all components to no avail. I checked the electrolytic capacitors, and they look fine (no bulging or leakage, measuring infinite resistance between the pins)
I am puzzled now what could it be: U4, U3, C5+/-, something else altogether? Again, this amp was working flawlessly for past 6 or so years.
Any help is greatly appreciated.
tube_dude
 
Posts: 13
Likes: 0 post
Liked in: 0 post
Joined: September 2nd, 2012, 11:54 pm
Country: United States (us)

Re: Mini³ stopped working

Postby amb » January 10th, 2019, 10:33 pm

It’s strange that your rail splitter check passes, yet there is -1.3V at U4 pin 3. The rail splitter’s output and U4 pin 3 are essentially the same node with a 330Ω in between (which shouldn’t drop significant voltage). What are you using as the ground reference when making this measurement?

With the above caveat, and assuming the rail splitter is ok, then the most likely culprit is a blown U4.
User avatar
amb
Site Admin
 
Posts: 10359
Likes: 175 posts
Liked in: 479 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)

Re: Mini³ stopped working

Postby tube_dude » January 10th, 2019, 11:27 pm

Thanks for the quick reply.
I am using IG as the reference for measurements. Yes, there is -1.3V on pin1 of U3.
What puzzles me about the U4 idea is that it appears that it is just amplifying the input it is given, although gain of 2 is strange.
One more thing I can add is that when the amp died (I was listening) I heard a faint high pitch noise after which the sound decayed and distortion set in over the span of a second or two (as some capacitor was presumably discharging). I'll order an U4 replacement. should I add something else to the order list now that I'm at it, just in case?
tube_dude
 
Posts: 13
Likes: 0 post
Liked in: 0 post
Joined: September 2nd, 2012, 11:54 pm
Country: United States (us)

Mini³ stopped working

Postby amb » January 11th, 2019, 12:08 am

U3 pin 1 is IG. So if you’re using IG as ground reference and measure U3 pin 1, you should have 0V, not -1.3V. (Puzzled)

U4 has unity gain (gain of 1). If -1.3V appears at its + input, then it should output -1.3V (both referenced to IG). That is, if U4 is working properly.

But U4’s input is IG, so it doesn’t amplify any signal. It simply provides a buffered virtual ground.
User avatar
amb
Site Admin
 
Posts: 10359
Likes: 175 posts
Liked in: 479 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)

Re: Mini³ stopped working

Postby tube_dude » January 11th, 2019, 7:36 pm

I should be more careful. I did not measure pin 1 of U3 directly, I measured one side of R1G, and it turned out I measured the op-amp side of it. So it indeed looks like U4 is blown.
tube_dude
 
Posts: 13
Likes: 0 post
Liked in: 0 post
Joined: September 2nd, 2012, 11:54 pm
Country: United States (us)

Re: Mini³ stopped working

Postby tube_dude » January 16th, 2019, 9:42 pm

Replaced U4, and music is playing again! In the process of desoldering, I managed to completely remove the soldering pad for pin1 of U4 from the PCB and had a brief moment of panic. Luckily pin1 is not connected in the U4 chip so no real damage done. Hopefully I don't need to replace op-amps again.
tube_dude
 
Posts: 13
Likes: 0 post
Liked in: 0 post
Joined: September 2nd, 2012, 11:54 pm
Country: United States (us)

Mini³ stopped working

Postby amb » January 16th, 2019, 11:06 pm

If you don’t have special SMD rework equipment, a safer method to remove the opamp is to cut the pins off the body with a sharp blade, remove the body, then use a soldering iron to gently “wipe” the pins away from their solder pads.

To prep the pads for the new opamp, heat a solder wick over them and move it around to remove the excess leftover solder.
User avatar
amb
Site Admin
 
Posts: 10359
Likes: 175 posts
Liked in: 479 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)


Return to Mini³ portable headphone amplifier

Who is online

Users browsing this forum: No registered users and 0 guests

Quick Links

AMB audio DIY resources
AMB audio shop

cron