[f] AMB on Facebook

[Need advice] Green LED keep blinking when charging

chi1

Moderator: MisterX

Re: [Need advice] Green LED keep blinking when charging

Postby superpong » August 8th, 2015, 11:00 pm

amb wrote:Look at your U1 chip. Is it a MCP73864? The behavior you describe seems to suggest that you have a MCP73862 instead. With MCP73862, the LED will blink green when the charge cycle is complete.


It is MCP73864. Should I replace with a new MCP73864?
superpong
 
Posts: 12
Likes: 0 post
Liked in: 0 post
Joined: May 6th, 2010, 5:37 am
Country: Thailand (th)

Re: [Need advice] Green LED keep blinking when charging

Postby amb » August 8th, 2015, 11:25 pm

Not sure. The only cause of a flashing green light on the MCP73864 is if it's overheating (see the datasheet). Are the LiPo battery cells new and the recommended type? Measure the voltage across each of them at the end of charge cycle. What are they? Do the other sanity checks pass?
User avatar
amb
Site Admin
 
Posts: 10420
Likes: 176 posts
Liked in: 492 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)

Re: [Need advice] Green LED keep blinking when charging

Postby superpong » August 9th, 2015, 3:54 am

amb wrote:Not sure. The only cause of a flashing green light on the MCP73864 is if it's overheating (see the datasheet). Are the LiPo battery cells new and the recommended type? Measure the voltage across each of them at the end of charge cycle. What are they? Do the other sanity checks pass?


OK I double checked.

- Temperature of my amp during playing and charging is normal in my opinion. Temperature of both batteries is very normal, not hot or warm.
- Lipo cells comply with suggestion in the mini3 thread. It's HM-4G6-Z-37 Walkera 3.7V 600mAh. I bought from --> http://www.ebay.com/itm/Two-2-HM-4G6-Z- ... 23551c79ae
- I let the amp keep playing music until batteries are depleted (no more sound outout). Then I connect the amp to the 9V adapter. the green led starts blink promptly. This is so strange.
- Here is measurement result.

(1) B+ B- = 7.35 and keep increasing during charging.
(2) OV B- = 7.34V
(2) OV B+ = 7.34V
(3) B+ COM = 3.68
(4) B- COM = -3.67
(5) LPW B- = 0 (almost 0V)

OL OG = 10.9 Mega Ohm
OR OG = 9 Mega ohm
OL IG = 1.8 Kohm
OR IG = 1.8Kohm
OG IG = Open circuit

One more thing I notice that output from my 9V adapter is about 11V (during charging). Would it be serious or may it harm my amp?
In general, I'm really happy with its musicality that this amp delivers except the fact that the charging behavior is so strange. However if it does not harm my amp, I may leave it as is.
Last edited by superpong on August 9th, 2015, 3:59 am, edited 1 time in total.
superpong
 
Posts: 12
Likes: 0 post
Liked in: 0 post
Joined: May 6th, 2010, 5:37 am
Country: Thailand (th)

Re: [Need advice] Green LED keep blinking when charging

Postby amb » August 9th, 2015, 3:59 am

The over-temperature I mentioned is not for the battery cells. It's for the MCP73864 itself. If your wall adapter is outputting 11V then that could explain it. You should get one that has regulated 9V DC output.
User avatar
amb
Site Admin
 
Posts: 10420
Likes: 176 posts
Liked in: 492 posts
Joined: March 29th, 2010, 9:49 pm
Location: Sunnyvale, CA
Country: United States (us)

Re: [Need advice] Green LED keep blinking when charging

Postby superpong » August 9th, 2015, 4:00 am

amb wrote:The over-temperature I mentioned is not for the battery cells. It's for the MCP73864 itself. If your wall adapter is outputting 11V then that could explain it. You should get one that has regulated 9V DC output.


OK many thanks
superpong
 
Posts: 12
Likes: 0 post
Liked in: 0 post
Joined: May 6th, 2010, 5:37 am
Country: Thailand (th)

Previous

Return to χ1 LiPo battery board for Mini³

Who is online

Users browsing this forum: No registered users and 0 guests

Quick Links

AMB audio DIY resources
AMB audio shop

cron